const regex = /(^[a-z]{1}(emi)|(m[a-z]{1}se))/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[a-z]{1}(emi)|(m[a-z]{1}se))', 'gim')
const str = `hemidemisemiquaver
emi - курсив
m.se - жирным
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}