$re = '/(^[a-z]{1}(emi)|(m[a-z]{1}se))/im';
$str = 'hemidemisemiquaver
emi - курсив
m.se - жирным
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);