re = /(^[a-z]{1}(emi)|(m[a-z]{1}se))/im
str = 'hemidemisemiquaver
emi - курсив
m.se - жирным
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end