// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(^[a-z]{1}(emi)|(m[a-z]{1}se))").unwrap();
let string = "hemidemisemiquaver
emi - курсив
m.se - жирным
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}