use strict;
my $str = 'http://regex101.com/r/mH1fN5
http://regex101.com/r/fW0vZ2';
my $regex = qr/^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})?$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";