import re
regex = re.compile(r"^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})?$", flags=re.MULTILINE)
test_str = ("http://regex101.com/r/mH1fN5\n"
"http://regex101.com/r/fW0vZ2")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)