// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})?$").unwrap();
let string = "http://regex101.com/r/mH1fN5
http://regex101.com/r/fW0vZ2";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}