re = /^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})?$/m
str = 'http://regex101.com/r/mH1fN5
http://regex101.com/r/fW0vZ2'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result