import Foundation
let pattern = #"^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://regex101.com/r/mH1fN5
http://regex101.com/r/fW0vZ2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)