using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[^\sCB]*A[^\sCB]*\b";
string input = @"ABCDE
ADE
DEFHI
BACHT
HIJKA LAZY YZAL LAZC BAZC FOO BAR PAR";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}