import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[^\\sCB]*A[^\\sCB]*\\b";
final String string = "ABCDE\n"
+ "ADE\n"
+ "DEFHI\n"
+ "BACHT\n"
+ "HIJKA LAZY YZAL LAZC BAZC FOO BAR PAR";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}