$re = '/\b[^\sCB]*A[^\sCB]*\b/m';
$str = 'ABCDE
ADE
DEFHI
BACHT
HIJKA LAZY YZAL LAZC BAZC FOO BAR PAR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);