re = /\b[^\sCB]*A[^\sCB]*\b/m
str = 'ABCDE
ADE
DEFHI
BACHT
HIJKA LAZY YZAL LAZC BAZC FOO BAR PAR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end