package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[^\sCB]*A[^\sCB]*\b`)
var str = `ABCDE
ADE
DEFHI
BACHT
HIJKA LAZY YZAL LAZC BAZC FOO BAR PAR`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}