#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[+-]\d+|(?:[01][0-9]|2[0-3]):[0-5][0-9])$"
Local $sString = "+120" & @CRLF & _
"-15" & @CRLF & _
"17:56" & @CRLF & _
"18:89" & @CRLF & _
"-" & @CRLF & _
"+"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")