import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[+-]\\d+|(?:[01][0-9]|2[0-3]):[0-5][0-9])$";
final String string = "+120\n"
+ "-15\n"
+ "17:56\n"
+ "18:89\n"
+ "-\n"
+ "+";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}