re = /^(?:[+-]\d+|(?:[01][0-9]|2[0-3]):[0-5][0-9])$/m
str = '+120
-15
17:56
18:89
-
+'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end