package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[+-]\d+|(?:[01][0-9]|2[0-3]):[0-5][0-9])$`)
var str = `+120
-15
17:56
18:89
-
+`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}