#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-zÀ-ÿ]{2,}([.-])?)+( ?(([A-zÀ-ÿ]){2,}([.-])?))* (([A-zÀ-ÿ]){2,}([.-])?)+$"
Local $sString = "xfbhc-xbfdfg fdhfdhdrhhdffh grgfdbdf ñÁ-ñÁ" & @CRLF & _
"" & @CRLF & _
"dfgffsdfd-dfggsgsg sr. sfefsg" & @CRLF & _
"" & @CRLF & _
"Roberto Jr." & @CRLF & _
"" & @CRLF & _
"Carlos-pablos Petrosyan jr." & @CRLF & _
"" & @CRLF & _
"carlos-pablos Petrosyan jr." & @CRLF & _
"" & @CRLF & _
"Rodrigo Jr. Ahora" & @CRLF & _
"" & @CRLF & _
"Gabriel Ira rodrigez. jr." & @CRLF & _
"" & @CRLF & _
"Gabriel Ira rodr-igez. jr." & @CRLF & _
"" & @CRLF & _
"Ira Gabriel rodb nman-jnir ngor" & @CRLF & _
"" & @CRLF & _
"Ira gabriel rodb nman-jnir. ngo" & @CRLF & _
"" & @CRLF & _
"Gabriel Jr. Ira rodr-igez jr-" & @CRLF & _
"" & @CRLF & _
"-------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"fdghdf dggdg dgdghdh dfff dgggddggdgh" & @CRLF & _
"" & @CRLF & _
"Gabriel Ira rodr-igez. jr. " & @CRLF & _
"" & @CRLF & _
"Gabriel Jr.. Ira rodr-igez. jr." & @CRLF & _
"" & @CRLF & _
"Gabriel.. Jr. Ira rodr-igez. jr." & @CRLF & _
"" & @CRLF & _
"rodrigo jr.. ahora" & @CRLF & _
"" & @CRLF & _
"knlknllk k fgjnfn" & @CRLF & _
"" & @CRLF & _
"hgh" & @CRLF & _
"" & @CRLF & _
"hgghrhgfnf" & @CRLF & _
"" & @CRLF & _
" jhdsbdhfbj" & @CRLF & _
"" & @CRLF & _
"dfvdfvf sdvds "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")