import Foundation
let pattern = #"^([A-zÀ-ÿ]{2,}([.-])?)+( ?(([A-zÀ-ÿ]){2,}([.-])?))* (([A-zÀ-ÿ]){2,}([.-])?)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
xfbhc-xbfdfg fdhfdhdrhhdffh grgfdbdf ñÁ-ñÁ
dfgffsdfd-dfggsgsg sr. sfefsg
Roberto Jr.
Carlos-pablos Petrosyan jr.
carlos-pablos Petrosyan jr.
Rodrigo Jr. Ahora
Gabriel Ira rodrigez. jr.
Gabriel Ira rodr-igez. jr.
Ira Gabriel rodb nman-jnir ngor
Ira gabriel rodb nman-jnir. ngo
Gabriel Jr. Ira rodr-igez jr-
-------------------------------------------------------------
fdghdf dggdg dgdghdh dfff dgggddggdgh
Gabriel Ira rodr-igez. jr.
Gabriel Jr.. Ira rodr-igez. jr.
Gabriel.. Jr. Ira rodr-igez. jr.
rodrigo jr.. ahora
knlknllk k fgjnfn
hgh
hgghrhgfnf
jhdsbdhfbj
dfvdfvf sdvds
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)