import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-zÀ-ÿ]{2,}([.-])?)+( ?(([A-zÀ-ÿ]){2,}([.-])?))* (([A-zÀ-ÿ]){2,}([.-])?)+$";
final String string = "xfbhc-xbfdfg fdhfdhdrhhdffh grgfdbdf ñÁ-ñÁ\n\n"
+ "dfgffsdfd-dfggsgsg sr. sfefsg\n\n"
+ "Roberto Jr.\n\n"
+ "Carlos-pablos Petrosyan jr.\n\n"
+ "carlos-pablos Petrosyan jr.\n\n"
+ "Rodrigo Jr. Ahora\n\n"
+ "Gabriel Ira rodrigez. jr.\n\n"
+ "Gabriel Ira rodr-igez. jr.\n\n"
+ "Ira Gabriel rodb nman-jnir ngor\n\n"
+ "Ira gabriel rodb nman-jnir. ngo\n\n"
+ "Gabriel Jr. Ira rodr-igez jr-\n\n"
+ "-------------------------------------------------------------\n\n"
+ "fdghdf dggdg dgdghdh dfff dgggddggdgh\n\n"
+ "Gabriel Ira rodr-igez. jr. \n\n"
+ "Gabriel Jr.. Ira rodr-igez. jr.\n\n"
+ "Gabriel.. Jr. Ira rodr-igez. jr.\n\n"
+ "rodrigo jr.. ahora\n\n"
+ "knlknllk k fgjnfn\n\n"
+ "hgh\n\n"
+ "hgghrhgfnf\n\n"
+ " jhdsbdhfbj\n\n"
+ "dfvdfvf sdvds ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}