#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,2}(?:[.,]\d{1,2})?$"
Local $sString = "9" & @CRLF & _
"" & @CRLF & _
"9.56" & @CRLF & _
"" & @CRLF & _
"9,56" & @CRLF & _
"" & @CRLF & _
"999" & @CRLF & _
"" & @CRLF & _
"50" & @CRLF & _
"" & @CRLF & _
"999.56" & @CRLF & _
"" & @CRLF & _
"50z" & @CRLF & _
"" & @CRLF & _
"50.75" & @CRLF & _
"" & @CRLF & _
"foo" & @CRLF & _
"" & @CRLF & _
"bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")