re = /^\d{1,2}(?:[.,]\d{1,2})?$/m
str = '9
9.56
9,56
999
50
999.56
50z
50.75
foo
bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end