import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,2}(?:[.,]\\d{1,2})?$";
final String string = "9\n\n"
+ "9.56\n\n"
+ "9,56\n\n"
+ "999\n\n"
+ "50\n\n"
+ "999.56\n\n"
+ "50z\n\n"
+ "50.75\n\n"
+ "foo\n\n"
+ "bar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}