package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,2}(?:[.,]\d{1,2})?$`)
var str = `9
9.56
9,56
999
50
999.56
50z
50.75
foo
bar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}