$re = '/^\d{1,2}(?:[.,]\d{1,2})?$/m';
$str = '9
9.56
9,56
999
50
999.56
50z
50.75
foo
bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);