# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^ \* @([a-z]+).*)(?=\r?\n^ \* @(?!\2))/$1\n */gm;t' <<< "/**
* Get Data
*
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
*/"