using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^ \* @([a-z]+).*)(?=\r?\n^ \* @(?!\2))";
string substitution = @"$1\n *";
string input = @"/**
* Get Data
*
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
*/";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}