$re = '/(^ \* @([a-z]+).*)(?=\r?\n^ \* @(?!\2))/m';
$str = '/**
* Get Data
*
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
*/';
$subst = "$1\n *";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;