use strict;
my $str = '/**
* Get Data
*
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
*/';
my $regex = qr/(^ \* @([a-z]+).*)(?=\r?\n^ \* @(?!\2))/mp;
my $subst = '$1\\n *';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";