#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*/gradle-wrapper\.jar$).*\.(?:jar|exe)$"
Local $sString = "rupe-engine/src/main/groovy/com/rupe/engine/JongoAutoConfiguration.java" & @CRLF & _
"" & @CRLF & _
"gradle/wrapper/gradle-wrapper.jar" & @CRLF & _
"" & @CRLF & _
"gradle/wrapper/gradle-bundle.exe" & @CRLF & _
"" & @CRLF & _
"gradle/wrapexe/gradle.git" & @CRLF & _
"" & @CRLF & _
"testit.jar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")