$re = '@^(?!.*/gradle-wrapper\.jar$).*\.(?:jar|exe)$@m';
$str = 'rupe-engine/src/main/groovy/com/rupe/engine/JongoAutoConfiguration.java
gradle/wrapper/gradle-wrapper.jar
gradle/wrapper/gradle-bundle.exe
gradle/wrapexe/gradle.git
testit.jar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);