re = /^(?!.*\/gradle-wrapper\.jar$).*\.(?:jar|exe)$/m
str = 'rupe-engine/src/main/groovy/com/rupe/engine/JongoAutoConfiguration.java
gradle/wrapper/gradle-wrapper.jar
gradle/wrapper/gradle-bundle.exe
gradle/wrapexe/gradle.git
testit.jar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end