import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*/gradle-wrapper\\.jar$).*\\.(?:jar|exe)$";
final String string = "rupe-engine/src/main/groovy/com/rupe/engine/JongoAutoConfiguration.java\n\n"
+ "gradle/wrapper/gradle-wrapper.jar\n\n"
+ "gradle/wrapper/gradle-bundle.exe\n\n"
+ "gradle/wrapexe/gradle.git\n\n"
+ "testit.jar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}