using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*/gradle-wrapper\.jar$).*\.(?:jar|exe)$";
string input = @"rupe-engine/src/main/groovy/com/rupe/engine/JongoAutoConfiguration.java
gradle/wrapper/gradle-wrapper.jar
gradle/wrapper/gradle-bundle.exe
gradle/wrapexe/gradle.git
testit.jar";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}