const regex = /^\d$|^\d\s\d$|^\d\s\d\s\d$|^\d\s\d\s\d\s\d$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d$|^\\d\\s\\d$|^\\d\\s\\d\\s\\d$|^\\d\\s\\d\\s\\d\\s\\d$', 'gm')
const str = `0
0 1
0 1 2
0 1 2 3
0
0 00
0 12 1 0
0
0
0
00
0 1 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}