import re
regex = re.compile(r"^\d$|^\d\s\d$|^\d\s\d\s\d$|^\d\s\d\s\d\s\d$", flags=re.MULTILINE)
test_str = ("0\n"
"0 1\n"
"0 1 2\n"
"0 1 2 3\n\n"
"0 \n"
"0 00\n"
"0 12 1 0\n"
" 0 \n"
" 0\n"
"0 \n"
"00\n"
"0 1 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")