re = /^\d$|^\d\s\d$|^\d\s\d\s\d$|^\d\s\d\s\d\s\d$/m
str = '0
0 1
0 1 2
0 1 2 3
0
0 00
0 12 1 0
0
0
0
00
0 1 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end