const regex = /^(\d+\s?(years?|months?|weeks?|days?|hours?|minutes?|min|mins?|seconds?|sec|secs?|y|M|w|d|h|m|s)\s?)+$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+\\s?(years?|months?|weeks?|days?|hours?|minutes?|min|mins?|seconds?|sec|secs?|y|M|w|d|h|m|s)\\s?)+$', 'i')
const str = `5 weeks 50m`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}