import re
regex = re.compile(r"^(\d+\s?(years?|months?|weeks?|days?|hours?|minutes?|min|mins?|seconds?|sec|secs?|y|M|w|d|h|m|s)\s?)+$", flags=re.IGNORECASE)
test_str = "5 weeks 50m"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")