re = /^(\d+\s?(years?|months?|weeks?|days?|hours?|minutes?|min|mins?|seconds?|sec|secs?|y|M|w|d|h|m|s)\s?)+$/i
str = '5 weeks 50m'
# Print the match result
str.match(re) do |match|
puts match.to_s
end