import Foundation
let pattern = #"^(\d+\s?(years?|months?|weeks?|days?|hours?|minutes?|min|mins?|seconds?|sec|secs?|y|M|w|d|h|m|s)\s?)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"5 weeks 50m"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}