package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[-?\d+[.]\d+,-?\d+[.]\d+\]`)
var str = `[10.6302565,-74.9131161]
[-10.6302565,-74.9131161]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}