re = /\[-?\d+[.]\d+,-?\d+[.]\d+\]/
str = '[10.6302565,-74.9131161]
[-10.6302565,-74.9131161]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end