// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[-?\d+[.]\d+,-?\d+[.]\d+\]").unwrap();
let string = "[10.6302565,-74.9131161]
[-10.6302565,-74.9131161]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}