import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<id>\\S+)\\s+(?<title>.*?)(?:\\s+(?<price>\\$\\d[\\d.]*))?\\s*(?<clearance>\\([^()]*\\))$";
final String string = "BK0001 PHP and MySQL Web Development (4th Edition) $49.95 (Clearance Price!)\n"
+ "BK0013 Wanna be a Master at PHP? (Free!)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}