const regex = /^(?<id>\S+)\s+(?<title>.*?)(?:\s+(?<price>\$\d[\d.]*))?\s*(?<clearance>\([^()]*\))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<id>\\S+)\\s+(?<title>.*?)(?:\\s+(?<price>\\$\\d[\\d.]*))?\\s*(?<clearance>\\([^()]*\\))$', 'gm')
const str = `BK0001 PHP and MySQL Web Development (4th Edition) \$49.95 (Clearance Price!)
BK0013 Wanna be a Master at PHP? (Free!)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}