import re
regex = re.compile(r"^(?<id>\S+)\s+(?<title>.*?)(?:\s+(?<price>\$\d[\d.]*))?\s*(?<clearance>\([^()]*\))$", flags=re.MULTILINE)
test_str = ("BK0001 PHP and MySQL Web Development (4th Edition) $49.95 (Clearance Price!)\n"
"BK0013 Wanna be a Master at PHP? (Free!)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")