$re = '/^(?<id>\S+)\s+(?<title>.*?)(?:\s+(?<price>\$\d[\d.]*))?\s*(?<clearance>\([^()]*\))$/m';
$str = 'BK0001 PHP and MySQL Web Development (4th Edition) $49.95 (Clearance Price!)
BK0013 Wanna be a Master at PHP? (Free!)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);