// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<id>\S+)\s+(?<title>.*?)(?:\s+(?<price>\$\d[\d.]*))?\s*(?<clearance>\([^()]*\))$").unwrap();
let string = "BK0001 PHP and MySQL Web Development (4th Edition) $49.95 (Clearance Price!)
BK0013 Wanna be a Master at PHP? (Free!)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}